Configuración mínima para Catalyst 2950-24
Servicio de la Universitat de València

Configuración mínima para Catalyst 2950-24

Datos necesarios

  • Número de VLAN del edificio donde se va a instalar: <vlan_ed>
  • Número de VLAN de gestión del campus donde se va a instalar: <vlan_gestion>
  • Nombre, IP, máscara, gateway de gestión, tras registrarlo en UVALRED: <nombre>, <ip>, <mascara>, <gateway>
  • Dominio VTP del campus donde se va a instalar: <dominio_vtp>
  • Edificio, planta, rack donde se va a instalar: <edificio>, <planta>, <rack>

Procedimiento

  1. Registrar los datos del comutador como dispositivo en UVALRED y tomar nota de los datos necesarios. Recordad que los lugares de conexión determinados para cada campus, con independencia del edificio son:
       Burjassot:     Electronicas de red Burjassot
       Blasco Ibañez: Electronicas de red Blasco Ibanez
       Tarongers:     Electronicas de red Tarongers
    
  2. Conectarse al conmutador con privilegios de administrador. Para una primera instalacion, el acceso al conmutador será por la consola:
       Switch> enable
       Switch# conf t
       Enter configuration commands, one per line.  End with CNTL/Z.
       Switch(config)#
    
  3. Tras introducir la configuración mínima, recordad grabarla:
       Switch(config)# exit
       Switch# write mem
    

Configuración mínima

service password-encryption
!
hostname <nombre>
!
enable secret 5 $1$blFS$SUYzCd4av2yxnK1gU2G7G0 
enable password 7 0820405A080F001B13
!
ip subnet-zero
ip domain-name uv.es
ip name-server 147.156.1.1
ip name-server 147.156.1.3
!
interface range FastEthernet0/1 - 24
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface range GigabitEthernet0/1 - 2
  switchport trunk native vlan <vlan_gestion>
  switchport mode trunk
!
interface VLAN1
 shutdown
!
interface VLAN<vlan_gestion>
 ip address <ip> <mascara>
 no ip directed-broadcast
 no ip route-cache
 no shutdown
!
ip default-gateway <gateway>
snmp-server location <edificio> - <planta> - <rack>
snmp-server contact hostmaster@uv.es 
!
line con 0   
  password 7 1212041B1B06091625
!
line vty 0 15
  password 7 1212041B1B06091625
!    
vtp domain <dominio_vtp>
vtp mode client


Instalación y configuración definitiva

  1. Usar, en la medida de lo posible, la boca gi0/1 para uplink (conexion al conmutador más próximo al núcleo de la red) y la boca gi0/2 para seguir el apilamiento.
  2. Si es necesario conectar una maquina en la boca gi0/2, se puede reconfigurar esta del siguiente modo una vez en trado en el nivel de configuración:
      interface GigabitEthernet0/2
       switchport mode access
       switchport access vlan <vlan_ed>
       spanning-tree portfast
    
  3. Si se desea aplicar la configuración definitiva al conmutador, tras la instalación física y tras comprobar que se dispone de conectividad, se puede realizar lo siguiente:
      cataXXXX#copy tftp://147.156.1.143/Cata2950/2950conf running-config
      Destination filename [running-config]? <intro>
      Loading Cata2950/2950conf from 147.156.1.143 (via VLAN60): !
      [OK - 2202 bytes]
      2202 bytes copied in 19.803 secs (115 bytes/sec)
      cataXXXX#write mem
    
  4. Comunicar la instalación del conmutador para su actualización de software.

Configuración definitiva

La configuración definitiva tendra aproximadamente este aspecto:

! Last configuration change at 09:11:50 MET-1ME Mon Aug 29 2005 by ciscoadm
! NVRAM config last updated at 09:11:52 MET-1ME Mon Aug 29 2005 by ciscoadm
!
version 12.1
no service pad
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname <nombre>
!
aaa new-model
aaa authentication login default group tacacs+ line
aaa authentication enable default group tacacs+ enable
aaa authorization exec default local group tacacs+ none
aaa accounting commands 15 default start-stop group tacacs+
aaa accounting connection default start-stop group tacacs+
enable password 7 0820405A080F001B13
!
clock timezone MET-1 1
clock summer-time MET-1METDST recurring last Sun Mar 2:00 last Sun Oct 3:00
ip subnet-zero
ip rcmd rsh-enable
ip rcmd remote-host ciscoadm 147.156.200.5 ciscoadm enable
ip rcmd remote-host ciscoadm 147.156.1.12 ciscoadm enable
!
ip domain-name uv.es
ip name-server 147.156.1.1
ip name-server 147.156.1.3
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/2
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/3
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/4
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/5
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/6
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/7
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/8
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/9
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/10
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/11
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/12
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/13
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/14
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!         
interface FastEthernet0/15
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/16
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/17
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/18
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/19
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/20
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/21
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/22
 switchport access vlan <vlan_ed>
 spanning-tree portfast
!
interface FastEthernet0/23
 switchport access vlan <vlan_ed>
!
interface FastEthernet0/24
 switchport access vlan <vlan_ed>
!
interface GigabitEthernet0/1
 switchport trunk native vlan <vlan_gestion>
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport trunk native vlan <vlan_gestion>
 switchport mode trunk
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan<vlan_gestion>
 ip address <ip> <mascara>
 no ip route-cache
!
ip default-gateway <gateway>
no ip http server
logging 147.156.1.12
access-list 21 permit 147.156.1.12
access-list 21 permit 147.156.1.95
access-list 21 permit 147.156.1.145
access-list 21 permit 147.156.200.5
access-list 22 permit 147.156.200.5
snmp-server community public RO 21
snmp-server community AqAASen213 RW 22
snmp-server location <edificio> - <planta> - <rack>
snmp-server contact hostmaster@uv.es 
snmp-server enable traps snmp authentication warmstart linkdown linkup coldstart
snmp-server enable traps config
snmp-server enable traps syslog
snmp-server enable traps entity
snmp-server enable traps rtr
snmp-server enable traps c2900
snmp-server enable traps vtp
snmp-server enable traps MAC-Notification
snmp-server enable traps envmon fan shutdown supply temperature
snmp-server enable traps hsrp
snmp-server enable traps cluster
snmp-server enable traps vlan-membership
snmp-server host 147.156.1.12 public 
tacacs-server host 147.156.200.5
tacacs-server host 147.156.9.7
tacacs-server key siuv
banner login ^CServei d'Informatica. Universitat de Valencia^C
!
line con 0
 password 7 1212041B1B06091625
line vty 0 4
 password 7 1212041B1B06091625
line vty 5 14
 password 7 1212041B1B06091625
line vty 15
 password 7 0704204047041C1718
!
ntp clock-period 17180003
ntp server 147.156.1.3
ntp server 147.156.1.135 prefer
!
end

volver